codentropy.com

Home > Dpkg Error > Dpkg Error Processing Libpam-winbind -configure

Dpkg Error Processing Libpam-winbind -configure

QIIIApril 6th, 2012, 01:31 AMIf you do choose to reinstall (maybe not such a bad idea, but I really don't like the "Nuke 'em from orbit" approach), consider the possibility that Do you want to continue [Y/n]? dpkg: error processing /var/cache/apt/archives/libc6_2.13-20ubuntu5.1_i386.deb (--unpack): corrupted filesystem tarfile - corrupted package archive dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/libc6_2.13-20ubuntu5.1_i386.deb E: Sub-process /usr/bin/dpkg Extract templates from packages: 100% Preconfiguring packages ... navigate here

Done The following packages were automatically installed and are no longer required: libhdb9-heimdal libkdc2-heimdal libntdb1 python-ntdb Use 'apt-get autoremove' to remove them. Preparing to unpack .../libtdb1_1.3.8-0ubuntu0.14.04.1_amd64.deb ... How to reproduce easily: $ cat /etc/nsswitch.conf passwd: winbind compat shadow: compat group: winbind compat (winbind is usually used after compat, in this case it was used before) to have samba I uninstalled those, then a cascade of other packages that caused problems, then ran do-release-upgrade to oneiric and to precise. this content

After this operation, 31.6 MB of additional disk space will be used. Whee. infinity: if the abi changes, running processes die because they're running with the old version of libnss-winbind infinity: I guess abi additions should be fine, but I'm not sure mdeslaur: Doesn't look like something one can properly fix in an SRU, since the fix is to actually version the *#^)! Salvatore Bonaccorso (supplier of updated samba package) (This message was generated automatically at their request; if you believe that there is a problem with it please contact the archive administrators

After this operation, 5,632 kB of additional disk space will be used. CardioStripteaseApril 6th, 2012, 01:11 AMI did all of those things. Unpacking libnss-winbind:amd64 (2:4.3.9+dfsg-0ubuntu0.14.04.1) over (2:4.1.6+dfsg-1ubuntu2.14.04.13) ... I'll ponder the problem over breakfast.

Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 164 Star 855 Fork 387 Veil-Framework/Veil-Evasion Code Issues 5 Pull requests 0 Projects perhaps that's not a problematic scenario mdeslaur: After taking a walk, it occurs to me that in the absence of proper library versioning, the more robust solution might just be To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1584485/+subscriptions Previous message: [Bug 1584485] [NEW] Upgrading samba to latest security fixes together with winbind in nsswitch.conf can harm entire OS Next message: NetAPP SMB servers don't negotiate NTLMSSP_SIGN. (Closes: #822937) . [ Steven Chamberlain ] * ctdb: Fix detection of gnukfreebsd (Closes: #802621) GNU/kFreeBSD's platform name is 'gnukfreebsd', not just 'kfreebsd'. . [

Even after following the directions in this post, any attempts to install or fix anything, including apt-get autoremove, give the following errors: % autoremove -f Reading package lists... Need to get 8,877 kB of archives. Before proceeding with the installation, or upgrade, make sure to disable winbind! samba-vfs-modules suggests no packages. -- no debconf information Added tag(s) confirmed.

lizardpunk commented Jan 12, 2016 sorry again, im newbie, i will put all the process [i] Ubuntu 14 i686 Detected... [?] Are you sure you wish to install Veil-Evasion? Already have an account? there would be always a time window for things to go bad [12:45] tinoco: The best solution would be for upstream to properly version all those little libs in samba-libs, if customer had a taylor made change of nsswitch.conf..

the proposal was to bring the discussion only [12:44] tinoco: Only statically linked to samba-libs, of course. http://codentropy.com/dpkg-error/dpkg-error-processing-python-apt-configure.html Attaching debdiffs... -- You received this bug notification because you are a member of Ubuntu Foundations Bugs, which is subscribed to samba in Ubuntu. The following extra packages will be installed: libldb1 libnss-winbind libpam-winbind libtdb1 libtevent0 libwbclient0 python-ldb python-samba python-tdb samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules winbind Suggested packages: bind9 bind9utils ldb-tools smbldap-tools heimdal-clients The following Message #17 received at [email protected] (full text, mbox, reply): From: Jelmer Vernooij To: [email protected] Subject: Bug#821070: fixed in samba 2:4.3.8+dfsg-1 Date: Sat, 16 Apr 2016 04:35:23 +0000 Source: samba Source-Version:

benedictbrownMay 29th, 2012, 05:03 AMI seemed to have solved my problems, although it wasn't pretty. Message #5 received at [email protected] (full text, mbox, reply): From: Raphaël Hertzog To: Debian Bug Tracking System Subject: samba-vfs-modules: File overwrite error on libnon-posix-acls.so.0 when upgrading from 4.2.10 in Attaching debdiffs... -- You received this bug notification because you are a member of Ubuntu Bugs, which is subscribed to Ubuntu. http://codentropy.com/dpkg-error/dpkg-error-processing-winbind-configure.html No errors.

oh, right, new processes in that specific case mdeslaur: But having samba-libs Break libnss-winbind << Binary-Version, and disable/reenable winbind on preinst/postinst would "work". Warning: You have winbind configured in either NSS (/etc/nsswitch.conf) or in PAM (/etc/pam.d/*). So, whenever trying to upgrade samba you will get something like: ---- Do you want to continue? [Y/n] y (Reading database ... 115473 files and directories currently installed.) Preparing to unpack

Any suggestions would be greatly appreciated.

Done The following packages were automatically installed and are no longer required:   libhdb9-heimdal libkdc2-heimdal libntdb1 python-ntdb Use 'apt-get autoremove' to remove them. After this operation, 5,632 kB of additional disk space will be used. Warning: You have winbind configured in either NSS (/etc/nsswitch.conf) or in PAM (/etc/pam.d/*). If you have further comments please address them to [email protected], and the maintainer will reopen the bug report if appropriate.

The following extra packages will be installed: attr binfmt-support binutils binutils-mingw-w64-i686 binutils-mingw-w64-x86-64 cabextract cli-common dkms fonts-horai-umefont fonts-wqy-microhei g++-mingw-w64 g++-mingw-w64-i686 g++-mingw-w64-x86-64 gcc-mingw-w64 gcc-mingw-w64-base gcc-mingw-w64-i686 gcc-mingw-w64-x86-64 geoclue-2.0 gfortran-mingw-w64 gfortran-mingw-w64-i686 gfortran-mingw-w64-x86-64 git-man glx-alternative-mesa glx-alternative-nvidia Preparing to unpack .../python-tdb_1.3.8-0ubuntu0.14.04.1_amd64.deb ... No further changes may be made. weblink I see that it's possible to install updates from the liveCD; can the same be done with a liveUSB?

Preparing to unpack .../nvidia-installer-cleanup_20141201+1_i386.deb ... Though, gross. Preparing to unpack .../libtevent0_0.9.28-0ubuntu0.14.04.1_amd64.deb ... Is it possible to get that package from somewhere else?

dpkg: error processing archive /var/cache/apt/archives/samba-libs_2%3a4.2.10+dfsg-0+deb8u2_amd64.deb (--unpack): trying to overwrite '/usr/lib/x86_64-linux-gnu/samba/libsmbd-base.so.0', which is also in package samba 2:4.2.10+dfsg-0+deb8u1 dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) This is what "Replaces" Exit Code: 100. The upgrade to 11.10 failed on libc6, leaving my system with a broken package system. Done python is already the newest version.

See original description Tags: patch sts Edit Tag help Rafael David Tinoco (inaddy) wrote on 2016-05-22: #1 Download full text (4.9 KiB) $ sudo apt-get --only-upgrade install samba Reading package lists... https://bugs.launchpad.net/bugs/1584485 Title: Upgrading samba to latest security fixes together with winbind in nsswitch.conf can harm entire OS To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1584485/+subscriptions -- ubuntu-bugs mailing list [email protected]

Border